CVE-2020-35572

NameCVE-2020-35572
DescriptionAdminer through 4.7.8 allows XSS via the history parameter to the default URI.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
adminer (PTS)stretch4.2.5-3+deb9u1fixed
stretch (security)4.2.5-3+deb9u2fixed
buster4.7.1-1vulnerable
bullseye, sid4.7.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
adminersourcestretch(not affected)
adminersource(unstable)4.7.9-1

Notes

[stretch] - adminer <not-affected> (Vulnerable code introduced in v4.7.0)
https://sourceforge.net/p/adminer/bugs-and-features/775/
https://github.com/vrana/adminer/security/advisories/GHSA-9pgx-gcph-mpqr
https://github.com/vrana/adminer/commit/5c395afc098e501be3417017c6421968aac477bd (v4.7.9)

Search for package or bug name: Reporting problems