CVE-2020-35653

NameCVE-2020-35653
DescriptionIn Pillow before 8.1.0, PcxDecode has a buffer over-read when decoding a crafted PCX file because the user-supplied stride value is trusted for buffer calculations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2716-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)stretch4.0.0-4+deb9u1vulnerable
stretch (security)4.0.0-4+deb9u3fixed
buster5.4.1-2+deb10u2vulnerable
buster (security)5.4.1-2+deb10u1vulnerable
bookworm, bullseye8.1.2+dfsg-0.3fixed
sid8.3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsourcestretch4.0.0-4+deb9u3DLA-2716-1
pillowsource(unstable)8.1.0-1

Notes

[buster] - pillow <no-dsa> (Minor issue)
https://pillow.readthedocs.io/en/stable/releasenotes/8.1.0.html#security
https://github.com/python-pillow/Pillow/pull/5174
https://github.com/python-pillow/Pillow/commit/2f409261eb1228e166868f8f0b5da5cda52e55bf

Search for package or bug name: Reporting problems