CVE-2020-35711

NameCVE-2020-35711
DescriptionAn issue has been discovered in the arc-swap crate before 0.4.8 (and 1.x before 1.1.0) for Rust. Use of arc_swap::access::Map with the Constant test helper (or with a user-supplied implementation of the Access trait) could sometimes lead to dangling references being returned by the map.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs985090

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rust-arc-swap (PTS)buster0.3.7-1vulnerable
bookworm, sid, bullseye0.4.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rust-arc-swapsource(unstable)0.4.8-1985090

Notes

[buster] - rust-arc-swap <no-dsa> (Minor issue)
https://github.com/vorner/arc-swap/issues/45
https://rustsec.org/advisories/RUSTSEC-2020-0091.html

Search for package or bug name: Reporting problems