CVE-2020-35730

NameCVE-2020-35730
DescriptionAn XSS issue was discovered in Roundcube Webmail before 1.2.13, 1.3.x before 1.3.16, and 1.4.x before 1.4.10. The attacker can send a plain text e-mail message, with JavaScript in a link reference element that is mishandled by linkref_addindex in rcube_string_replacer.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2508-1, DSA-4821-1
NVD severitymedium
Debian Bugs978491

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
roundcube (PTS)stretch1.2.3+dfsg.1-4+deb9u6vulnerable
stretch (security)1.2.3+dfsg.1-4+deb9u8fixed
buster1.3.15+dfsg.1-1~deb10u1vulnerable
buster (security)1.3.16+dfsg.1-1~deb10u1fixed
bullseye1.4.10+dfsg.1-1fixed
sid1.4.10+dfsg.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
roundcubesourcestretch1.2.3+dfsg.1-4+deb9u8DLA-2508-1
roundcubesourcebuster1.3.16+dfsg.1-1~deb10u1DSA-4821-1
roundcubesource(unstable)1.4.10+dfsg.1-1978491

Notes

https://github.com/roundcube/roundcubemail/commit/0bceba301aa621ecc0263eac17beee2a4cef0c6d (1.4.10)
https://github.com/roundcube/roundcubemail/commit/a06ec1dcf9c972d302b16e1ac6aa079a4f6a1c3e (1.3.16)
https://github.com/roundcube/roundcubemail/commit/47e4d44f62ea16f923761d57f1773a66d51afad4 (1.2.13)

Search for package or bug name: Reporting problems