CVE-2020-35914

NameCVE-2020-35914
DescriptionAn issue was discovered in the lock_api crate before 0.4.2 for Rust. A data race can occur because of RwLockWriteGuard unsoundness.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs975319, 1032854

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rust-lock-api (PTS)buster0.1.5-1vulnerable
bullseye0.3.4-1vulnerable
bookworm0.4.9-1fixed
trixie, sid0.4.11-1fixed
rust-lock-api-0.1 (PTS)bullseye0.1.5-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rust-lock-apisource(unstable)0.4.5-1975319
rust-lock-api-0.1source(unstable)(unfixed)1032854

Notes

[bullseye] - rust-lock-api <no-dsa> (Minor issue)
[buster] - rust-lock-api <no-dsa> (Minor issue)
[bullseye] - rust-lock-api-0.1 <no-dsa> (Minor issue)
https://rustsec.org/advisories/RUSTSEC-2020-0070.html
https://github.com/Amanieu/parking_lot/pull/262

Search for package or bug name: Reporting problems