CVE-2020-35916

NameCVE-2020-35916
DescriptionAn issue was discovered in the image crate before 0.23.12 for Rust. A Mutable reference has immutable provenance. (In the case of LLVM, the IR may be always correct.)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs976869

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rust-image (PTS)sid0.22.1-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rust-imagesource(unstable)(unfixed)976869

Notes

https://rustsec.org/advisories/RUSTSEC-2020-0073.html
https://github.com/image-rs/image/issues/1357

Search for package or bug name: Reporting problems