CVE-2020-36224

NameCVE-2020-36224
DescriptionA flaw was discovered in OpenLDAP before 2.4.57 leading to an invalid pointer free and slapd crash in the saslAuthzTo processing, resulting in denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2544-1, DSA-4845-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openldap (PTS)stretch2.4.44+dfsg-5+deb9u4vulnerable
stretch (security)2.4.44+dfsg-5+deb9u8fixed
buster, buster (security)2.4.47+dfsg-3+deb10u6fixed
bullseye, sid2.4.57+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openldapsourcestretch2.4.44+dfsg-5+deb9u7DLA-2544-1
openldapsourcebuster2.4.47+dfsg-3+deb10u5DSA-4845-1
openldapsource(unstable)2.4.57+dfsg-1

Notes

https://bugs.openldap.org/show_bug.cgi?id=9409
https://git.openldap.org/openldap/openldap/-/commit/554dff1927176579d652f2fe60c90e9abbad4c65 (OPENLDAP_REL_ENG_2_4_57)
https://git.openldap.org/openldap/openldap/-/commit/c0b61a9486508e5202aa2e0cfb68c9813731b439 (OPENLDAP_REL_ENG_2_4_57)
https://git.openldap.org/openldap/openldap/-/commit/5a2017d4e61a6ddc4dcb4415028e0d08eb6bca26 (OPENLDAP_REL_ENG_2_4_57)
https://git.openldap.org/openldap/openldap/-/commit/d169e7958a3e0dc70f59c8374bf8a59833b7bdd8 (OPENLDAP_REL_ENG_2_4_57)
CVE-2020-36224, CVE-2020-36225 and CVE-2020-36226 are related but differend ids

Search for package or bug name: Reporting problems