CVE-2020-36277

NameCVE-2020-36277
DescriptionLeptonica before 1.80.0 allows a denial of service (application crash) via an incorrect left shift in pixConvert2To8 in pixconv.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2612-1
NVD severitymedium
Debian Bugs985089

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
leptonlib (PTS)stretch1.74.1-1vulnerable
stretch (security)1.74.1-1+deb9u1fixed
buster1.76.0-1vulnerable
bookworm, sid, bullseye1.79.0-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
leptonlibsourcestretch1.74.1-1+deb9u1DLA-2612-1
leptonlibsource(unstable)1.79.0-1.1985089

Notes

[buster] - leptonlib <no-dsa> (Minor issue)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=21997
https://github.com/DanBloomberg/leptonica/pull/499

Search for package or bug name: Reporting problems