CVE-2020-36311

NameCVE-2020-36311
DescriptionAn issue was discovered in the Linux kernel before 5.9. arch/x86/kvm/svm/sev.c allows attackers to cause a denial of service (soft lockup) by triggering destruction of a large SEV VM (which requires unregistering many encrypted regions), aka CID-7be74942f184.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2714-1, DSA-4941-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1fixed
stretch (security)4.9.272-2fixed
buster4.19.194-1vulnerable
buster (security)4.19.194-3fixed
bullseye5.10.46-2fixed
sid5.10.46-3fixed
linux-4.19 (PTS)stretch (security)4.19.194-3~deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcestretch(not affected)
linuxsourcebuster4.19.194-3DSA-4941-1
linuxsource(unstable)5.9.1-1
linux-4.19sourcestretch4.19.194-3~deb9u1DLA-2714-1

Notes

[stretch] - linux <not-affected> (Vulnerable code not present)
https://git.kernel.org/linus/7be74942f184fdfba34ddd19a0d995deb34d4a03

Search for package or bug name: Reporting problems