CVE-2020-36317

NameCVE-2020-36317
DescriptionIn the standard library in Rust before 1.49.0, String::retain() function has a panic safety problem. It allows creation of a non-UTF-8 Rust string when the provided closure panics. This bug could result in a memory safety violation when other string APIs assume that UTF-8 encoding is used on the same string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs986803

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rustc (PTS)stretch1.34.2+dfsg1-1~deb9u1vulnerable
stretch (security)1.41.1+dfsg1-1~deb9u1vulnerable
buster1.41.1+dfsg1-1~deb10u1vulnerable
bullseye, sid1.48.0+dfsg1-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rustcsource(unstable)(unfixed)986803

Notes

[bullseye] - rustc <no-dsa> (Minor issue)
[buster] - rustc <no-dsa> (Minor issue)
[stretch] - rustc <no-dsa> (Minor issue)
https://github.com/rust-lang/rust/issues/78498
https://github.com/rust-lang/rust/pull/78499

Search for package or bug name: Reporting problems