CVE-2020-36658

NameCVE-2020-36658
DescriptionIn Apache::Session::LDAP before 0.5, validity of the X.509 certificate is not checked by default when connecting to remote LDAP backends, because the default configuration of the Net::LDAPS module for Perl is used. NOTE: this can, for example, be fixed in conjunction with the CVE-2020-16093 fix.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3284-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapache-session-ldap-perl (PTS)buster0.4-1vulnerable
buster (security)0.4-1+deb10u1fixed
sid, trixie, bookworm, bullseye0.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache-session-ldap-perlsourcebuster0.4-1+deb10u1DLA-3284-1
libapache-session-ldap-perlsource(unstable)0.5-1

Notes

Fixed by: https://github.com/LemonLDAPNG/Apache-Session-LDAP/commit/490722b71eed1ed1ab33d58c78578f23e043561f (v0.5)

Search for package or bug name: Reporting problems