CVE-2020-36829

NameCVE-2020-36829
DescriptionThe Mojolicious module before 8.65 for Perl is vulnerable to secure_compare timing attacks that allow an attacker to guess the length of a secret string. Only versions after 1.74 are affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libmojolicious-perl (PTS)buster8.12+dfsg-1vulnerable
bullseye8.71+dfsg-1fixed
bookworm9.31+dfsg-1fixed
sid, trixie9.37+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libmojolicious-perlsource(unstable)8.65+dfsg-1

Notes

https://github.com/mojolicious/mojo/pull/1601 (v8.65)
https://github.com/mojolicious/mojo/issues/1599

Search for package or bug name: Reporting problems