CVE-2020-4031

NameCVE-2020-4031
DescriptionIn FreeRDP before version 2.1.2, there is a use-after-free in gdi_SelectObject. All FreeRDP clients using compatibility mode with /relax-order-checks are affected. This is fixed in version 2.1.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freerdp (PTS)stretch1.1.0~git20140921.1.440916e+dfsg1-13+deb9u3vulnerable
stretch (security)1.1.0~git20140921.1.440916e+dfsg1-13+deb9u4vulnerable
freerdp2 (PTS)buster2.0.0~git20190204.1.2693389a+dfsg1-1+deb10u2vulnerable
bullseye, sid2.2.0+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freerdpsource(unstable)(unfixed)
freerdp2source(unstable)2.1.2+dfsg1-1

Notes

[buster] - freerdp2 <no-dsa> (Minor issue)
[stretch] - freerdp <no-dsa> (Minor issue)
https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-gwcq-hpq2-m74g

Search for package or bug name: Reporting problems