DescriptionIn Sanitize (RubyGem sanitize) greater than or equal to 3.0.0 and less than 5.2.1, there is a cross-site scripting vulnerability. When HTML is sanitized using Sanitize's "relaxed" config, or a custom config that allows certain elements, some content in a math or svg element may not be sanitized correctly even if math and svg are not in the allowlist. You are likely to be vulnerable to this issue if you use Sanitize's relaxed config or a custom config that allows one or more of the following HTML elements: iframe, math, noembed, noframes, noscript, plaintext, script, style, svg, xmp. Using carefully crafted input, an attacker may be able to sneak arbitrary HTML through Sanitize, potentially resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser. This has been fixed in 5.2.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs963808

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-sanitize (PTS)bullseye (security), bullseye5.2.1-2+deb11u1fixed
bookworm, bookworm (security)6.0.0-1.1+deb12u1fixed
sid, trixie6.0.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-sanitizesourcejessie(not affected)
ruby-sanitizesourcestretch(not affected)


[stretch] - ruby-sanitize <not-affected> (Vulnerable code introduced later)
[jessie] - ruby-sanitize <not-affected> (Vulnerable code introduced later)
Fixed by: (v5.2.1)
Only in 5.0.0 removing of useless filtered elements content is done by default
with: (v5.0.0)

Search for package or bug name: Reporting problems