CVE-2020-5313

NameCVE-2020-5313
DescriptionlibImaging/FliDecode.c in Pillow before 6.2.2 has an FLI buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2057-1, DSA-4631-1
NVD severitymedium
Debian Bugs948224

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)stretch4.0.0-4+deb9u1fixed
stretch (security)4.0.0-4+deb9u2fixed
buster5.4.1-2+deb10u2fixed
buster (security)5.4.1-2+deb10u1fixed
bullseye, sid7.2.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsourcejessie2.6.1-2+deb8u4DLA-2057-1
pillowsourcestretch4.0.0-4+deb9u1DSA-4631-1
pillowsourcebuster5.4.1-2+deb10u1DSA-4631-1
pillowsource(unstable)7.0.0-1948224

Notes

https://github.com/python-pillow/Pillow/commit/a09acd0decd8a87ccce939d5ff65dab59e7d365b (6.2.2)

Search for package or bug name: Reporting problems