CVE-2020-5398

NameCVE-2020-5398
DescriptionIn Spring Framework, versions 5.2.x prior to 5.2.3, versions 5.1.x prior to 5.1.13, and versions 5.0.x prior to 5.0.16, an application is vulnerable to a reflected file download (RFD) attack when it sets a "Content-Disposition" header in the response where the filename attribute is derived from user supplied input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libspring-java (PTS)jessie3.0.6.RELEASE-17fixed
jessie (security)3.0.6.RELEASE-17+deb8u1fixed
stretch4.3.5-1vulnerable
bullseye, sid, buster4.3.22-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libspring-javasource(unstable)(unfixed)
libspring-javasourcejessie(not affected)

Notes

[jessie] - libspring-java <not-affected> (Vulnerable code not present)
https://pivotal.io/security/cve-2020-5398
https://github.com/spring-projects/spring-framework/issues/24220
https://github.com/spring-projects/spring-framework/commit/41f40c6c229d3b4f768718f1ec229d8f0ad76d76
https://github.com/spring-projects/spring-framework/commit/956ffe68587c8d5f21135b5ce4650af0c2dea933

Search for package or bug name: Reporting problems