CVE-2020-5421

NameCVE-2020-5421
DescriptionIn Spring Framework versions 5.2.0 - 5.2.8, 5.1.0 - 5.1.17, 5.0.0 - 5.0.18, 4.3.0 - 4.3.28, and older unsupported versions, the protections against RFD attacks from CVE-2015-5211 may be bypassed depending on the browser used through the use of a jsessionid path parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs973381

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libspring-java (PTS)buster4.3.22-4vulnerable
bullseye4.3.30-1fixed
bookworm, sid, trixie4.3.30-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libspring-javasource(unstable)4.3.30-1unimportant973381

Notes

https://tanzu.vmware.com/security/cve-2020-5421
https://github.com/spring-projects/spring-framework/issues/26821 (patch unidentifiable)
Only supported for building applications shipped in Debian, see README.Debian.security

Search for package or bug name: Reporting problems