CVE-2020-5504

NameCVE-2020-5504
DescriptionIn phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page. A malicious user could inject custom SQL in place of their own username when creating queries to this page. An attacker must have a valid MySQL account to access the server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2060-1
NVD severitymedium
Debian Bugs948718

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)jessie4:4.2.12-2+deb8u2vulnerable
jessie (security)4:4.2.12-2+deb8u9fixed
stretch4:4.6.6-4vulnerable
bullseye, sid4:4.9.5+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)4:4.9.4+dfsg1-1948718
phpmyadminsourcejessie4:4.2.12-2+deb8u8DLA-2060-1

Notes

[stretch] - phpmyadmin <no-dsa> (Minor issue; can be fixed via point release)
https://github.com/phpmyadmin/phpmyadmin/commit/c86acbf3ed49f69cf38b31879886dd5eb86b6983
https://gist.github.com/ibennetch/4c1b701f4b766e4dd5556e8e26200b6b
https://www.phpmyadmin.net/security/PMASA-2020-1/

Search for package or bug name: Reporting problems