CVE-2020-5991

NameCVE-2020-5991
DescriptionNVIDIA CUDA Toolkit, all versions prior to 11.1.1, contains a vulnerability in the NVJPEG library in which an out-of-bounds read or write operation may lead to code execution, denial of service, or information disclosure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs973543

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nvidia-cuda-toolkit (PTS)stretch/non-free8.0.44-4vulnerable
buster/non-free9.2.148-7vulnerable
sid/non-free, bullseye/non-free11.1.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nvidia-cuda-toolkitsourceexperimental11.1.1-1
nvidia-cuda-toolkitsource(unstable)11.1.1-2973543

Notes

[buster] - nvidia-cuda-toolkit <ignored> (Non-free not supported)
[stretch] - nvidia-cuda-toolkit <ignored> (Non-free not supported)
https://nvidia.custhelp.com/app/answers/detail/a_id/5094

Search for package or bug name: Reporting problems