CVE-2020-6625

NameCVE-2020-6625
Descriptionjhead through 3.04 has a heap-based buffer over-read in Get32s when called from ProcessGpsInfo in gpsinfo.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jhead (PTS)jessie1:2.97-1+deb8u1vulnerable
jessie (security)1:2.97-1+deb8u2vulnerable
stretch1:3.00-4+deb9u1vulnerable
buster1:3.00-8vulnerable
bullseye, sid1:3.04-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jheadsource(unstable)(unfixed)unimportant

Notes

https://bugs.launchpad.net/ubuntu/+source/jhead/+bug/1858746
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems