CVE-2020-6796

NameCVE-2020-6796
DescriptionA content process could have modified shared memory relating to crash reporting information, crash itself, and cause an out-of-bound write. This could have caused memory corruption and a potentially exploitable crash. This vulnerability affects Firefox < 73 and Firefox < ESR68.5.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2102-1, DSA-4620-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid79.0-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1fixed
stretch (security)68.11.0esr-1~deb9u1fixed
buster68.10.0esr-1~deb10u1fixed
buster (security)68.11.0esr-1~deb10u1fixed
bullseye, sid68.11.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)73.0-1
firefox-esrsourcejessie68.5.0esr-1~deb8u1DLA-2102-1
firefox-esrsourcestretch68.5.0esr-1~deb9u1DSA-4620-1
firefox-esrsourcebuster68.5.0esr-1~deb10u1DSA-4620-1
firefox-esrsource(unstable)68.5.0esr-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2020-05/#CVE-2020-6796
https://www.mozilla.org/en-US/security/advisories/mfsa2020-06/#CVE-2020-6796

Search for package or bug name: Reporting problems