CVE-2020-6802

NameCVE-2020-6802
DescriptionIn Mozilla Bleach before 3.11, a mutation XSS affects users calling bleach.clean with noscript and a raw tag in the allowed/whitelisted tags option.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4636-1
NVD severitymedium
Debian Bugs951907

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-bleach (PTS)stretch2.0-1vulnerable
buster, buster (security)3.1.2-0+deb10u1fixed
bullseye, sid3.1.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-bleachsourcebuster3.1.1-0+deb10u1DSA-4636-1
python-bleachsource(unstable)3.1.1-1951907

Notes

[stretch] - python-bleach <ignored> (Requires invasive changes to address issue)
[jessie] - python-bleach <ignored> (Fix too invasive in jessie; uses external html5 parser)
https://bugzilla.mozilla.org/show_bug.cgi?id=1615315 (not public)
https://github.com/mozilla/bleach/security/advisories/GHSA-q65m-pv3f-wr5r
https://github.com/mozilla/bleach/commit/f77e0f6392177a06e46a49abd61a4d9f035e57fd

Search for package or bug name: Reporting problems