CVE-2020-6805

NameCVE-2020-6805
DescriptionWhen removing data about an origin whose tab was recently closed, a use-after-free could occur in the Quota manager, resulting in a potentially exploitable crash. This vulnerability affects Thunderbird < 68.6, Firefox < 74, Firefox < ESR68.6, and Firefox ESR < 68.6.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2140-1, DLA-2150-1, DSA-4639-1, DSA-4642-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid103.0-1fixed
firefox-esr (PTS)buster78.14.0esr-1~deb10u1fixed
buster (security)91.12.0esr-1~deb10u1fixed
bullseye91.11.0esr-1~deb11u1fixed
bullseye (security)91.12.0esr-1~deb11u1fixed
bookworm91.11.0esr-1fixed
sid91.12.0esr-1fixed
thunderbird (PTS)buster1:78.14.0-1~deb10u1fixed
buster (security)1:91.12.0-1~deb10u1fixed
bullseye1:91.10.0-1~deb11u1fixed
bullseye (security)1:91.12.0-1~deb11u1fixed
bookworm1:91.10.0-1fixed
sid1:102.1.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)74.0-1
firefox-esrsourcejessie68.6.0esr-1~deb8u1DLA-2140-1
firefox-esrsourcestretch68.6.0esr-1~deb9u1DSA-4639-1
firefox-esrsourcebuster68.6.0esr-1~deb10u1DSA-4639-1
firefox-esrsource(unstable)68.6.0esr-1
thunderbirdsourcejessie1:68.6.0-1~deb8u1DLA-2150-1
thunderbirdsourcestretch1:68.6.0-1~deb9u1DSA-4642-1
thunderbirdsourcebuster1:68.6.0-1~deb10u1DSA-4642-1
thunderbirdsource(unstable)1:68.6.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2020-10/#CVE-2020-6805
https://www.mozilla.org/en-US/security/advisories/mfsa2020-09/#CVE-2020-6805
https://www.mozilla.org/en-US/security/advisories/mfsa2020-08/#CVE-2020-6805

Search for package or bug name: Reporting problems