CVE-2020-6819

NameCVE-2020-6819
DescriptionUnder certain conditions, when running the nsDocShell destructor, a race condition can cause a use-after-free. We are aware of targeted attacks in the wild abusing this flaw. This vulnerability affects Thunderbird < 68.7.0, Firefox < 74.0.1, and Firefox ESR < 68.6.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2170-1, DLA-2172-1, DSA-4653-1, DSA-4656-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid93.0-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1fixed
stretch (security)78.15.0esr-1~deb9u1fixed
buster78.14.0esr-1~deb10u1fixed
buster (security)78.15.0esr-1~deb10u1fixed
bullseye78.14.0esr-1~deb11u1fixed
bullseye (security)78.15.0esr-1~deb11u1fixed
bookworm78.14.0esr-1fixed
sid91.2.0esr-1fixed
thunderbird (PTS)stretch1:68.10.0-1~deb9u1fixed
stretch (security)1:78.14.0-1~deb9u1fixed
buster, buster (security)1:78.14.0-1~deb10u1fixed
bullseye (security), bullseye1:78.14.0-1~deb11u1fixed
bookworm1:78.14.0-1fixed
sid1:91.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)74.0.1-1
firefox-esrsourcejessie68.7.0esr-1~deb8u1DLA-2170-1
firefox-esrsourcestretch68.6.1esr-1~deb9u1DSA-4653-1
firefox-esrsourcebuster68.6.1esr-1~deb10u1DSA-4653-1
firefox-esrsource(unstable)68.6.1esr-1
thunderbirdsourcejessie1:68.7.0-1~deb8u1DLA-2172-1
thunderbirdsourcestretch1:68.7.0-1~deb9u1DSA-4656-1
thunderbirdsourcebuster1:68.7.0-1~deb10u1DSA-4656-1
thunderbirdsource(unstable)1:68.7.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2020-11/#CVE-2020-6819
https://www.mozilla.org/en-US/security/advisories/mfsa2020-14/#CVE-2020-6819

Search for package or bug name: Reporting problems