CVE-2020-7677

NameCVE-2020-7677
DescriptionThis affects the package thenify before 3.3.1. The name argument provided to the package can be controlled by users without any sanitization, and this is provided to the eval function without any sanitization.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-thenify (PTS)buster3.3.0-1vulnerable
bullseye3.3.1-1fixed
bookworm, sid3.3.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-thenifysource(unstable)3.3.1-1

Notes

https://security.snyk.io/vuln/SNYK-JS-THENIFY-571690
https://github.com/thenables/thenify/commit/0d94a24eb933bc835d568f3009f4d269c4c4c17a (3.3.1)

Search for package or bug name: Reporting problems