CVE-2020-8124

NameCVE-2020-8124
DescriptionInsufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-url-parse (PTS)stretch1.0.5-2+deb9u1vulnerable
buster1.2.0-2+deb10u1fixed
bullseye, sid1.4.7+repack-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-url-parsesourcebuster1.2.0-2+deb10u1
node-url-parsesource(unstable)1.4.7-1

Notes

[stretch] - node-url-parse <ignored> (Nodejs in stretch not covered by security support)
https://github.com/unshiftio/url-parse/commit/3ecd256f127c3ada36a84d9b8dd3ebd14316274b
https://hackerone.com/reports/496293

Search for package or bug name: Reporting problems