CVE-2020-8159

NameCVE-2020-8159
DescriptionThere is a vulnerability in actionpack_page-caching gem < v1.2.1 that allows an attacker to write arbitrary files to a web server, potentially resulting in remote code execution if the attacker can write unescaped ERB to a view.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs960680

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-actionpack-page-caching (PTS)stretch1.0.2-4vulnerable
bullseye, sid, buster1.1.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-actionpack-page-cachingsource(unstable)(unfixed)960680

Notes

https://groups.google.com/forum/#!topic/rubyonrails-security/CFRVkEytdP8

Search for package or bug name: Reporting problems