CVE-2020-8172

NameCVE-2020-8172
DescriptionTLS session reuse can lead to host certificate verification bypass in node version < 12.18.0 and < 14.4.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nodejs (PTS)stretch4.8.2~dfsg-1fixed
buster10.19.0~dfsg1-1fixed
buster (security)10.21.0~dfsg-1~deb10u1fixed
bullseye10.21.0~dfsg-1fixed
sid12.18.1~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nodejssource(unstable)(not affected)

Notes

- nodejs <not-affected> (Only affects 12.x and later)
https://nodejs.org/en/blog/vulnerability/june-2020-security-releases/#tls-session-reuse-can-lead-to-host-certificate-verification-bypass-high-cve-2020-8172

Search for package or bug name: Reporting problems