CVE-2020-8174

NameCVE-2020-8174
Descriptionnapi_get_value_string_*() allows various kinds of memory corruption
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4696-1
Debian Bugs962145

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nodejs (PTS)stretch4.8.2~dfsg-1vulnerable
buster10.19.0~dfsg1-1vulnerable
buster (security)10.21.0~dfsg-1~deb10u1fixed
bullseye10.21.0~dfsg-1fixed
sid12.18.1~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nodejssource(unstable)10.21.0~dfsg-1962145
nodejssourcebuster10.21.0~dfsg-1~deb10u1DSA-4696-1
nodejssourcejessie(unfixed)end-of-life

Notes

[stretch] - nodejs <ignored> (Nodejs in stretch not covered by security support)
[jessie] - nodejs <end-of-life> (Nodejs in jessie not covered by security support)
https://nodejs.org/en/blog/vulnerability/june-2020-security-releases/#napi_get_value_string_-allows-various-kinds-of-memory-corruption-high-cve-2020-8174

Search for package or bug name: Reporting problems