CVE-2020-8177

NameCVE-2020-8177
Descriptioncurl 7.20.0 through 7.70.0 is vulnerable to improper restriction of names for files and other resources that can lead too overwriting a local file when the -J flag is used.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2295-1, DSA-4881-1
NVD severitymedium
Debian Bugs965281

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)stretch7.52.1-5+deb9u10vulnerable
stretch (security)7.52.1-5+deb9u13fixed
buster7.64.0-4+deb10u1vulnerable
buster (security)7.64.0-4+deb10u2fixed
bullseye, sid7.74.0-1.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcestretch7.52.1-5+deb9u11DLA-2295-1
curlsourcebuster7.64.0-4+deb10u2DSA-4881-1
curlsource(unstable)7.72.0-1965281

Notes

https://curl.haxx.se/docs/CVE-2020-8177.html
https://github.com/curl/curl/commit/8236aba58542c5f89f1d41ca09d84579efb05e22 (7.71.0)

Search for package or bug name: Reporting problems