CVE-2020-8185

NameCVE-2020-8185
DescriptionA denial of service vulnerability exists in Rails <6.0.3.2 that allowed an untrusted user to run any pending migrations on a Rails app running in production.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs964081

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)stretch2:4.2.7.1-1+deb9u2fixed
stretch (security)2:4.2.7.1-1+deb9u3fixed
buster2:5.2.2.1+dfsg-1+deb10u1fixed
bullseye2:5.2.4.3+dfsg-2fixed
sid2:6.0.3.2+dfsg-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssourceexperimental6.0.3.2+dfsg-1964081
railssource(unstable)(not affected)

Notes

- rails <not-affected> (Introduced in rails 6.x)
https://groups.google.com/g/rubyonrails-security/c/pAe9EV8gbM0

Search for package or bug name: Reporting problems