CVE-2020-8201

NameCVE-2020-8201
DescriptionNode.js < 12.18.4 and < 14.11 can be exploited to perform HTTP desync attacks and deliver malicious payloads to unsuspecting users. The payloads can be crafted by an attacker to hijack user sessions, poison cookies, perform clickjacking, and a multitude of other attacks depending on the architecture of the underlying system. The attack was possible due to a bug in processing of carrier-return symbols in the HTTP header names.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nodejs (PTS)stretch4.8.2~dfsg-1fixed
buster, buster (security)10.21.0~dfsg-1~deb10u1fixed
bullseye, sid12.18.4~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nodejssourcestretch(not affected)
nodejssourcebuster(not affected)
nodejssource(unstable)12.18.4~dfsg-1

Notes

[buster] - nodejs <not-affected> (Only affects 12.x and later)
[stretch] - nodejs <not-affected> (Only affects 12.x and later)
https://nodejs.org/en/blog/vulnerability/september-2020-security-releases/#http-request-smuggling-due-to-cr-to-hyphen-conversion-high-cve-2020-8201

Search for package or bug name: Reporting problems