CVE-2020-8203

NameCVE-2020-8203
DescriptionPrototype pollution attack when using _.zipObjectDeep in lodash <= 4.17.15.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs965283

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-lodash (PTS)stretch4.16.6+dfsg-2vulnerable
buster4.17.11+dfsg-2+deb10u1vulnerable
bullseye, sid4.17.19+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-lodashsourcestretch(unfixed)end-of-life
node-lodashsource(unstable)4.17.19+dfsg-1965283

Notes

[buster] - node-lodash <no-dsa> (Minor issue; can be fixed via point release)
[stretch] - node-lodash <end-of-life> (Nodejs in stretch not covered by security support)
https://hackerone.com/reports/712065

Search for package or bug name: Reporting problems