CVE-2020-8563

NameCVE-2020-8563
DescriptionIn Kubernetes clusters using VSphere as a cloud provider, with a logging level set to 4 or above, VSphere cloud credentials will be leaked in the cloud controller manager's log. This affects < v1.19.3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kubernetes (PTS)bullseye1.20.2-1fixed
sid1.20.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kubernetessource(unstable)(not affected)

Notes

- kubernetes <not-affected> (Only affects 19.x)
https://github.com/kubernetes/kubernetes/pull/95236
https://groups.google.com/g/kubernetes-announce/c/ScdmyORnPDk
https://github.com/kubernetes/kubernetes/issues/95621

Search for package or bug name: Reporting problems