CVE-2020-8564

NameCVE-2020-8564
DescriptionIn Kubernetes clusters using a logging level of at least 4, processing a malformed docker config file will result in the contents of the docker config file being leaked, which can include pull secrets or other registry credentials. This affects < v1.19.3, < v1.18.10, < v1.17.13.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs972341

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kubernetes (PTS)bullseye1.20.2-1fixed
sid1.20.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kubernetessource(unstable)1.19.3-1972341

Notes

https://github.com/kubernetes/kubernetes/pull/94712
https://groups.google.com/g/kubernetes-announce/c/ScdmyORnPDk
https://github.com/kubernetes/kubernetes/issues/95622

Search for package or bug name: Reporting problems