CVE-2020-9355

NameCVE-2020-9355
Descriptiondanfruehauf NetworkManager-ssh before 1.2.11 allows privilege escalation because extra options are mishandled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4637-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
network-manager-ssh (PTS)stretch1.2.1-1vulnerable
stretch (security)1.2.1-1+deb9u1fixed
buster1.2.10-1vulnerable
buster (security)1.2.10-1+deb10u1fixed
bullseye, sid1.2.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
network-manager-sshsource(unstable)1.2.11-1
network-manager-sshsourcebuster1.2.10-1+deb10u1DSA-4637-1
network-manager-sshsourcestretch1.2.1-1+deb9u1DSA-4637-1

Notes

https://github.com/danfruehauf/NetworkManager-ssh/pull/98
https://github.com/danfruehauf/NetworkManager-ssh/commit/5d88cd89795352b5df54cc0ebb6a0076b8c89ee4
https://bugzilla.redhat.com/show_bug.cgi?id=1803499

Search for package or bug name: Reporting problems