CVE-2020-9488

NameCVE-2020-9488
DescriptionImproper validation of certificate with host mismatch in Apache Log4j SMTP appender. This could allow an SMTPS connection to be intercepted by a man-in-the-middle attack which could leak any log messages sent through that appender. Fixed in Apache Log4j 2.12.3 and 2.13.1
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2852-1
Debian Bugs959450

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache-log4j2 (PTS)buster2.17.1-1~deb10u1fixed
buster (security)2.17.0-1~deb10u1fixed
bullseye2.17.1-1~deb11u1fixed
bullseye (security)2.17.0-1~deb11u1fixed
bookworm, sid2.17.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache-log4j2sourcestretch2.12.3-0+deb9u1DLA-2852-1
apache-log4j2sourcebuster2.15.0-1~deb10u1
apache-log4j2source(unstable)2.13.3-1959450

Notes

[jessie] - apache-log4j2 <no-dsa> (Minor issue; set mail.smtp.ssl.checkserveridentity to true to enable hostname verification)
https://www.openwall.com/lists/oss-security/2020/04/25/1
https://issues.apache.org/jira/browse/LOG4J2-2819
https://gitbox.apache.org/repos/asf?p=logging-log4j2.git;h=6851b5083ef9610bae320bf07e1f24d2aa08851b (release-2.x)
https://gitbox.apache.org/repos/asf?p=logging-log4j2.git;h=fb91a3d71e2f3dadad6fd1beb2ab857f44fe8bbb (master)

Search for package or bug name: Reporting problems