CVE-2021-0326

NameCVE-2021-0326
DescriptionIn p2p_copy_client_info of p2p.c, there is a possible out of bounds write due to a missing bounds check. This could lead to remote code execution if the target device is performing a Wi-Fi Direct search, with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-10 Android-11 Android-8.1 Android-9Android ID: A-172937525
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2572-1
NVD severityhigh
Debian Bugs981971

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)stretch2:2.4-1+deb9u6vulnerable
stretch (security)2:2.4-1+deb9u9fixed
buster2:2.7+git20190128+0c1e29f-6+deb10u2vulnerable
buster (security)2:2.7+git20190128+0c1e29f-6+deb10u1vulnerable
bullseye2:2.9.0-20fixed
sid2:2.9.0-21fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wpasourcestretch2:2.4-1+deb9u8DLA-2572-1
wpasource(unstable)2:2.9.0-17981971

Notes

https://www.openwall.com/lists/oss-security/2021/02/03/4
https://w1.fi/security/2020-2/wpa_supplicant-p2p-group-info-processing-vulnerability.txt
https://w1.fi/security/2020-2/0001-P2P-Fix-copying-of-secondary-device-types-for-P2P-gr.patch
https://w1.fi/cgit/hostap/commit/?id=947272febe24a8f0ea828b5b2f35f13c3821901e

Search for package or bug name: Reporting problems