CVE-2021-20214

NameCVE-2021-20214
DescriptionA flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the client-tags CGI handler when client tags are configured and memory allocations fail can lead to a system crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
privoxy (PTS)stretch3.0.26-3fixed
stretch (security)3.0.26-3+deb9u2fixed
buster3.0.28-2+deb10u1fixed
bullseye3.0.32-2fixed
sid, bookworm3.0.32-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
privoxysourcestretch(not affected)
privoxysourcebuster3.0.28-2+deb10u1
privoxysource(unstable)3.0.29-1

Notes

[stretch] - privoxy <not-affected> (Vulnerable code not present)
https://www.openwall.com/lists/oss-security/2021/02/03/3
https://www.privoxy.org/gitweb/?p=privoxy.git;a=commit;h=cf5640eb2a57197717758e225ad6e11cbaab1d6c (3.0.29)

Search for package or bug name: Reporting problems