CVE-2021-20215

NameCVE-2021-20215
DescriptionA flaw was found in Privoxy in versions before 3.0.29. Memory leaks in the show-status CGI handler when memory allocations fail can lead to a system crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2548-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
privoxy (PTS)stretch3.0.26-3vulnerable
stretch (security)3.0.26-3+deb9u2fixed
buster3.0.28-2+deb10u1fixed
bullseye, sid3.0.32-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
privoxysourcestretch3.0.26-3+deb9u1DLA-2548-1
privoxysourcebuster3.0.28-2+deb10u1
privoxysource(unstable)3.0.29-1

Notes

https://www.openwall.com/lists/oss-security/2021/02/03/3
https://www.privoxy.org/gitweb/?p=privoxy.git;a=commit;h=064eac5fd0f693e94ec8b3a64d1d91e8fb7e8e66 (3.0.29)
https://www.privoxy.org/gitweb/?p=privoxy.git;a=commit;h=fdee85c0bf3e2dbd7722ddc45e9ed912f02a2136 (3.0.29)

Search for package or bug name: Reporting problems