CVE-2021-20216

NameCVE-2021-20216
DescriptionA flaw was found in Privoxy in versions before 3.0.31. A memory leak that occurs when decompression fails unexpectedly may lead to a denial of service. The highest threat from this vulnerability is to system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2548-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
privoxy (PTS)stretch3.0.26-3vulnerable
stretch (security)3.0.26-3+deb9u2fixed
buster3.0.28-2+deb10u1fixed
bullseye3.0.32-2fixed
bookworm, sid3.0.32-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
privoxysourcestretch3.0.26-3+deb9u1DLA-2548-1
privoxysourcebuster3.0.28-2+deb10u1
privoxysource(unstable)3.0.31-1

Notes

https://www.openwall.com/lists/oss-security/2021/01/31/2
https://www.privoxy.org/gitweb/?p=privoxy.git;a=commit;h=f431d61740cc03c1c5f6b7f9c7a4a8d0bedd70dd (3.0.31)

Search for package or bug name: Reporting problems