CVE-2021-20228

NameCVE-2021-20228
DescriptionA flaw was found in the Ansible Engine 2.9.18, where sensitive info is not masked by default and is not protected by the no_log feature when using the sub-option feature of the basic.py module. This flaw allows an attacker to obtain sensitive information. The highest threat from this vulnerability is to confidentiality.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4950-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ansible (PTS)stretch2.2.1.0-2+deb9u1vulnerable
stretch (security)2.2.1.0-2+deb9u2vulnerable
buster2.7.7+dfsg-1vulnerable
buster (security)2.7.7+dfsg-1+deb10u1fixed
bookworm, bullseye, sid2.10.7+merged+base+2.10.8+dfsg-1fixed
ansible-base (PTS)bookworm, sid2.10.5+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ansiblesourcebuster2.7.7+dfsg-1+deb10u1DSA-4950-1
ansiblesource(unstable)2.10.7+merged+base+2.10.8+dfsg-1
ansible-basesource(unstable)(unfixed)

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1925002
https://github.com/ansible/ansible/pull/73487

Search for package or bug name: Reporting problems