CVE-2021-20231

NameCVE-2021-20231
DescriptionA flaw was found in gnutls. A use after free issue in client sending key_share extension may lead to memory corruption and other consequences.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls28 (PTS)stretch3.5.8-5+deb9u5fixed
stretch (security)3.5.8-5+deb9u1fixed
buster3.6.7-4+deb10u6vulnerable
buster (security)3.6.7-4+deb10u4vulnerable
bullseye, sid3.7.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls28sourcestretch(not affected)
gnutls28source(unstable)3.7.1-1

Notes

[buster] - gnutls28 <no-dsa> (Minor issue)
[stretch] - gnutls28 <not-affected> (Vulnerable code introduced later)
https://www.gnutls.org/security-new.html#GNUTLS-SA-2021-03-10
https://gitlab.com/gnutls/gnutls/-/issues/1151

Search for package or bug name: Reporting problems