CVE-2021-20272

NameCVE-2021-20272
DescriptionA flaw was found in privoxy before 3.0.32. An assertion failure could be triggered with a crafted CGI request leading to server crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2587-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
privoxy (PTS)stretch3.0.26-3vulnerable
stretch (security)3.0.26-3+deb9u2fixed
buster3.0.28-2+deb10u1fixed
bullseye3.0.32-2fixed
bookworm, sid3.0.32-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
privoxysourcestretch3.0.26-3+deb9u2DLA-2587-1
privoxysourcebuster3.0.28-2+deb10u1
privoxysource(unstable)3.0.32-1

Notes

https://www.openwall.com/lists/oss-security/2021/02/28/1
https://www.privoxy.org/gitweb/?p=privoxy.git;a=commit;h=2256d7b4d67dd9c364386877d5af59943433458b

Search for package or bug name: Reporting problems