CVE-2021-20718

NameCVE-2021-20718
Descriptionmod_auth_openidc 2.4.0 to 2.4.7 allows a remote attacker to cause a denial-of-service (DoS) condition via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs989055

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapache2-mod-auth-openidc (PTS)buster2.3.10.2-1+deb10u1fixed
buster (security)2.3.10.2-1+deb10u4fixed
bullseye (security), bullseye2.4.9.4-0+deb11u3fixed
bookworm2.4.12.3-2fixed
sid, trixie2.4.15.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache2-mod-auth-openidcsourcestretch(not affected)
libapache2-mod-auth-openidcsourcebuster(not affected)
libapache2-mod-auth-openidcsource(unstable)2.4.4.1-2989055

Notes

[buster] - libapache2-mod-auth-openidc <not-affected> (Vulnerable code introduced later)
[stretch] - libapache2-mod-auth-openidc <not-affected> (Vulnerable code introduced later)
https://github.com/zmartzone/mod_auth_openidc/commit/5ef1b0a74208fcb43a16795d0afc94c3d54cd120

Search for package or bug name: Reporting problems