CVE-2021-21408

NameCVE-2021-21408
DescriptionSmarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.43 and 4.0.3, template authors could run restricted static php methods. Users should upgrade to version 3.1.43 or 4.0.3 to receive a patch.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
smarty3 (PTS)stretch3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u1vulnerable
stretch (security)3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u4vulnerable
buster3.1.33+20180830.1.3a78a21f+selfpack1-1vulnerable
bullseye3.1.39-1vulnerable
bookworm, sid3.1.39-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
smarty3source(unstable)(unfixed)

Notes

https://github.com/smarty-php/smarty/security/advisories/GHSA-4h9c-v5vg-5m6m
https://github.com/smarty-php/smarty/commit/28519ca00fe6890ef2d464f8400a16188c4b6f36 (3.1.43)

Search for package or bug name: Reporting problems