CVE-2021-21775

NameCVE-2021-21775
DescriptionA use-after-free vulnerability exists in the way certain events are processed for ImageLoader objects of Webkit WebKitGTK 2.30.4. A specially crafted web page can lead to a potential information leak and further memory corruption. In order to trigger the vulnerability, a victim must be tricked into visiting a malicious webpage.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4945-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)stretch2.18.6-1~deb9u1vulnerable
buster, buster (security)2.32.4-1~deb10u1fixed
bullseye (security), bullseye2.32.4-1~deb11u1fixed
bookworm, sid2.34.0-1fixed
wpewebkit (PTS)bullseye (security), bullseye2.32.4-1~deb11u1fixed
bookworm, sid2.32.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.32.3-1~deb10u1DSA-4945-1
webkit2gtksource(unstable)2.32.3-1
wpewebkitsource(unstable)2.32.3-1

Notes

[bullseye] - webkit2gtk <postponed> (Fix along with next update round)
[buster] - webkit2gtk <postponed> (Fix along with next update round)
[stretch] - webkit2gtk <ignored> (Not covered by security support in stretch)
[bullseye] - wpewebkit <postponed> (Minor issue, fix along with next update)
https://talosintelligence.com/vulnerability_reports/TALOS-2021-1229

Search for package or bug name: Reporting problems