CVE-2021-22060

NameCVE-2021-22060
DescriptionIn Spring Framework versions 5.3.0 - 5.3.13, 5.2.0 - 5.2.18, and older unsupported versions, it is possible for a user to provide malicious input to cause the insertion of additional log entries. This is a follow-up to CVE-2021-22096 that protects against additional types of input and in more places of the Spring Framework codebase.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libspring-java (PTS)stretch4.3.5-1vulnerable
stretch (security)4.3.5-1+deb9u1vulnerable
buster4.3.22-4vulnerable
bookworm, sid, bullseye4.3.30-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libspring-javasourcestretch(unfixed)end-of-life
libspring-javasource(unstable)(unfixed)

Notes

[stretch] - libspring-java <end-of-life> (EOL'd for stretch)
follow-up to CVE-2021-22096
https://tanzu.vmware.com/security/cve-2021-22060

Search for package or bug name: Reporting problems