CVE-2021-22096

NameCVE-2021-22096
DescriptionIn Spring Framework versions 5.3.0 - 5.3.10, 5.2.0 - 5.2.17, and older unsupported versions, it is possible for a user to provide malicious input to cause the insertion of additional log entries.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libspring-java (PTS)stretch4.3.5-1vulnerable
stretch (security)4.3.5-1+deb9u1vulnerable
buster4.3.22-4vulnerable
bookworm, sid, bullseye4.3.30-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libspring-javasource(unstable)(unfixed)

Notes

[bullseye] - libspring-java <no-dsa> (Minor issue)
[buster] - libspring-java <no-dsa> (Minor issue)
[stretch] - libspring-java <ignored> (Minor issue, no known patch)
https://github.com/spring-projects/spring-framework/issues/27647 (patch unidentifiable)

Search for package or bug name: Reporting problems