CVE-2021-22174

NameCVE-2021-22174
DescriptionCrash in USB HID dissector in Wireshark 3.4.0 to 3.4.2 allows denial of service via packet injection or crafted capture file
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs981791

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)stretch2.6.7-1~deb9u1fixed
stretch (security)2.6.20-0+deb9u1fixed
buster2.6.20-0+deb10u1fixed
bullseye, sid3.4.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourcestretch(not affected)
wiresharksourcebuster(not affected)
wiresharksource(unstable)3.4.3-1981791

Notes

[buster] - wireshark <not-affected> (Affected code not present)
[stretch] - wireshark <not-affected> (Affected code not present)
https://www.wireshark.org/security/wnpa-sec-2021-02.html
https://gitlab.com/wireshark/wireshark/-/issues/17165

Search for package or bug name: Reporting problems